Start a new topic

Quick fix for Titanium not building using version 5.5.0.GA

Quick fix for Titanium not building using version 5.5.0.GA

Thanks for posting this as I've been struggling with this error.  I just installed the 5.5.1 release that they just pushed out and still get the same error.


Hey, i made the change but xcode is not letting me build the project . i keep getting errors in xcode.


I raised this issue with Appcelerator with a link to this topic. Here is what they had to say:


from Appcelerator
 to me

30 Sep


Seems it is a problem from Wikitude module, which is not created or maintained by us. 

I afraid our engineer team will not handle that, as all of our own modules are working well now.


So how are we going to fix this because tha above answer is not working ??

If you should experience the following error when building your application with the 5.5.0.GA Titanium SDK version (or related), this thread might provide a fix for your issue.



:  The following build commands failed:

:      Ld build/Intermediates/ normal armv7

:  (1 failure)


When building for an iOS target, Titanium generates an Xcode project that seems to have a configuration issue; namely missing specific linker flags for the Titanium core libraries. To correct this issue, navigate to the <YOUR_PROJECT_ROOT>/build/iphone/ directory. Within it you should find the module.xcconfig file. It should contain a line that reads COM_WIKITUDE_TI_OTHER_LDFLAGS_sdk_iphoneos__=$(inherited) $(WT_TIMODULE_LDFLAGS). If you append $(TICORE_LD_FLAGS) such that it reads COM_WIKITUDE_TI_OTHER_LDFLAGS_sdk_iphoneos__=$(inherited) $(TICORE_LD_FLAGS) $(WT_TIMODULE_LDFLAGS) you should be able to build your app using the Xcode project from the same directory.


Please note that this procedure is a crude fix intended to allow builds to succeed in the short term until this issue has been officially hotfixed by a future Titanium SDK release.


Additionally note, that the resulting Xcode project has the 'In-App Purchase' and 'Wireless Accessory Configuration' entitlements enabled. Should your App ID not support these entitlements, you will also encounter an error.


EDIT 05.10.2016:


Instead of following the fix I presented previously, I would recommend replacing the module.xcconfig file in the <sample_root>/modules/iphone/com.wikitude.ti/5.3.0 directory with the module.xcconfig file I attached to this answer. This should eliminate the necessity of fidgeting with the xcconfig file again and again upon building and allow for builds to work from within Appcelerator Studio as usual again.


This much more practical fix has been kindly suggested by one of our customers.


Naturally, the next release of the Wikitude SDK will include this fix.



Kind Regards



Hi everybody,


as we have still been getting reports regarding this issue, I would like to point out that I edited my original post and added an additional solution which should work for everybody and be less cumbersome to implement.

Please make sure you try it before asking for further assistance. Also note, that the original solution only fixes the device build, if you build for the simulator, the need to adjust the fix accordingly. The new fix, however, should take care of both targets.


Kind regards


After updating from Xcode 7 to Xcode 8 this build error appears with newest Wikitude 5.3.0 beta as well as Wikitude 5.3.0 as well as Wikitude 5.2.0 Tititanium module.
Further, we tested with several Titanium versions (Titanium SDK 5.4.0, 5.5.0, 5.5.1).

??Replacing module.xcconfig brings no effect.

Use 5.3.0 beta module with the attached "module.xcconfig" file in the installed module folder. I can confirm that it works.

We are struggeling over the various module installation pathes (output location during module installation):

- whole Titanium SDK: path_to_user_dir/Library/Application Support/Titanium/modules/iphone/com.wikitude.ti/

- project only: path_to_project/modules/iphone/com.wikitude.ti/

Now the fix works with the 5.3.0 module (also with the non-beta) !


A comparison of xcconfig files shows the crucial point for the build error.

5.3.0 / 5.3.0 beta:

Login or Signup to post a comment