Start a new topic

App crash at setlicencekey

App crash at setlicencekey

1 person has this problem


I have a look at it and let you know once I need more information or have a explanation.

Best regards,


Hi Huang, Frank,

Could you please try our SDK example application with your license key (Please make sure that you use the example app that was included with your SDK download package as we released a new version or our SDK just a few days ago and your exiting license key is not valid with this version anymore)?

So far I tried our Xamarin Component example with your license key in release configuration and had no issues. Could you send us a project that crashes? I would like to have a closer look at it.

Best regards,


I am currently using Wikitude SDK 5.3.0. 

Last few days, I was testing the new version and the 2D tracking and Geo is working. I submitted that copy to the App Store. Today, when the updated app is released in the App Store, the app crashes. I discovered that the app crash at setlicencekey. 

I double checked the licence to ensure that it is correct and the bundle identifier is correct too. 

I downloaded the sample SDK app to try using the purchased license key and bundle identifier , and it says unlicensed key.

For immediate assistance as the app is live in the app store that crashes. 


When you see the message Unlicensed Key/Feature then it means that you are trying to do something that you cannot do based on the license key you have bought. For instance, if you have purchased a Lite SDK and you are trying to do image recognition then you should see the message mentioned above, since with a Lite license you can only do GeoLocation features.


Realized that the app crash at setlicencekey is not about the license key. 

I tried removing the valid architectures arm64 and it worked on the devices, but apple requires arm64. 

Same issues here with the xamarin component 5.3.0. With build configuration armv7+arm64 i get a crash on setLicenceKey() in release build. Without arm64 there are no crashes but like Huang said, apple requires arm64. I have atteched my crash log.

Login or Signup to post a comment