Start a new topic

Cordova Run/Build Error

Cordova Run/Build Error

So far I've tried PhoneGap, result Build Failed.

Tried Cordova, result Build Failed - see attached screen shot - Gradle error.

Tried Intel XDK, result Build Failed, Gradle not support.

Tried Appcelerator Titantium, with your sample files, can't run them.

Is the last option ? Are there any other options?

Multiple days wasted on all the above now.


Hi John,

I think this is a problem that is not related with the Wikitude SDK. Maybe this link could help you investigate further.


I tried installing the JDK, but nothing seemed to happed, so re-booted my PC and now I can run the app with Cordova.

However the app won't load the AR.  (Using your default demo app)

It doesn't seem to get past this line in index.js, the cordova.file.applicationDirectory seems to be the problem:

if ( example.path.length > cordova.file.applicationDirectory ) {



These are the debug messages I see in the Android Studio console:


W/cr_BindingManager: Cannot call determinedVisibility() - never saw a connection for the pid: 26433

D/OpenGLRenderer: endAllStagingAnimators on 0x9bdc4d80 (RippleDrawable) with handle 0x9bf8aba0

W/PluginManager: THREAD WARNING: exec() call to WikitudePlugin.isDeviceSupported blocked the main thread for 124ms. Plugin should use CordovaInterface.getThreadPool().

I/chromium: "Error in Success callbackId: WikitudePlugin1393081572 : TypeError: Cannot read property 'dataDirectory' of undefined", source: file:///android_asset/www/cordova.js (312)

I/chromium: "Uncaught (in promise) TypeError: Cannot read property 'dataDirectory' of undefined", source: file:///android_asset/www/js/index.js (67)


Hi Jon,
Seems like the Cordova file plugin is not installed. Our example project generation script tries to add this in line 113. Can you find any Cordova file plugin related files in your project?

Best regards,

Login or Signup to post a comment