Start a new topic

Ambient Light on Blender 3D Models

Ambient Light on Blender 3D Models


Can you try the following: 

1. add a point light to the scene
2. set the color of that light to your preferred ambient light value
3. set it to invisible (i.e. disable the eye icon) in the scene graph view

Export the model to fbx and convert it with the encoder.

I had some problems loading of the wt3, but maybe it works with your version of the SDK. That is, no guarantee that it works.

A fix for the import problems is ready and will be available with the next release of the SDK.

 

Thanks, I'll check that out. Could I see if it works on the 3D Encoder or may I upload to the Studio?

The ambient light is not a light source which you can attach, but it's a global setting of the scene. Please consult the Blender manual for seeing how you can check the value for your 3D model. 

The ambient color of your fbx is black (0,0,0). So it's either a wrong setting or a bug of Blender's fbx exporter.

I'm not sure about this. In Blender's engine which is compatible with FBX there is no ambient light as it. Also, you only support one light. The problem is that the shadows are pure black and I want to have some light there as it was discussed in this thread: https://support.wikitude.com/support/search/topics?term=3D+lighting+and+material

The problem of that post is that they ended up talking about coding or something like that.

You should stick to the light source types supported by the 3D encoder, that is, directional and point lights. 

What's the color of your scene's ambient light in Blender? 

Hi! Here is an example: https://www.dropbox.com/s/2lbmwitum0m6h7p/Blender%20Hemi%20Light.fbx?dl=0

Originally, the light was a Hemi Light but the light is a Directional Light into the 3D Encoder.

Can you provide the fbx file, please?
(Either attach it here publicly or send an email to support@wikitude.com with the fbx file attached.)

I'm making some 3D models with Blender and everything is OK but the light.I would like to have an ambient light because the shadows are completely black.

The problem is that no light in Blender is taken as an ambient one. I thought that the Hemi light would be treated as an ambient light but the 3D Encoder thinks that is a Directional Light too. Also, the there's no option for semi-emitter materials so I cannot control the lightning in the shadows.

Any help with this? Thanks in advance!
Login or Signup to post a comment