Start a new topic

(Urgent) Failed open wikitude in IOS

(Urgent) Failed open wikitude in IOS

Hi, thank you for viewing my post and i'm newbie on xcode but my project required to integrate with Wikitude SDK into my project. Anyone can help me or any suggestion?

Framework - IBM Mobilefirst 7.1 Hybrid Application

My problem - i have follow sample code from but xcode throw error as below when using cordova.exec to call this wikitude SDK.

*** WebKit discarded an uncaught exception in the webView:decidePolicyForNavigationAction:request:frame:decisionListener: delegate: <NSInvalidArgumentException> Unable to parse constraint format: 

Unable to interpret '|' character, because the related view doesn't have a superview 



My hybrid part - 

cordova.exec(success, fail, "CameraPlugin", "launchCamera", );


My config.xml -

<feature name="CameraPlugin">

        <param name="ios-package" value="CameraPlugin" />



My class object(CameraPlugin.h) -

#import <Cordova/CDV.h>



@interface CameraPlugin : CDVPlugin


- (void)launchCamera:(CDVInvokedUrlCommand*)command;




My class object(CameraPlugin.m) -

-(void)launchCamera:(CDVInvokedUrlCommand *)command


    CDVPluginResult* pluginResult = nil;

    NSError *deviceSupportError=nil;



    if() {

            NSLog(@"Device is supported Wikitude SDK");


            //CDVMainViewController *view = (CDVMainViewController*);


            NSLog(@"=== View is configure ===");

            self.architectView = ;

            self.architectView.delegate = self;

            self.architectView.debugDelegate = self;


            NSLog(@"=== LicenseKey is configure");



            NSLog(@"=== URL loading ===");

            self.architectWorldNavigation = ;


            NSLog(@"Observer is configure");





            NSLog(@"Subview is configure");


            self.architectView.translatesAutoresizingMaskIntoConstraints = NO;


            NSDictionary *views = NSDictionaryOfVariableBindings(_architectView);




            NSLog(@"Result is configure");

            pluginResult = ;

        } else {

            NSLog(@"This device is not supported. Show either an alert or use this class method even before presenting the view controller that manages the WTArchitectView. Error: %@", );

            pluginResult = ;






Hi Jeffrey,
Two things that seem a little bit odd:

* Is there a particular reason why you try to write a new Cordova plugin that uses our SDK instead of our already existing Wikitude Cordova plugin?
* Your error message says that the architectView object has no superview. Did you make sure that self.view is not nil when you call

Best regards


Hi Andreas,

Thanks for reply/comment.

1. My application is existing application cannot be simply used cordova plugin SDK(i thought because i will override my application behavior), please correct me if i m wrong since i'm new into this.

2. I tried to "Go To Definition" by click self.view and it is pointing to my CDVMainViewController, i think it should be correct and not a nil object?

Best regards,


Hi Jeffrey,
1) If your application is a existing cordova managed application, you simply can add a new plugin everytime you want.

2) 'Go To Definition' is not a runtime check. Going to definition just shows you the type of self.view but not if it's nil at runtime or not. That you need to ensure at runtime (set a breakpoint or add a log output)

Best regards


Hi Andreas,

For your suggestion, i have tried to proceed checking on my self.view in logcat and i realized it's nil object so i had changed it as self.view = ; and it doesn't error anymore but it doesn't prompt wikitude camera even it's go thru startWikitudeSDKRendering without any error. What did wrong until here?

2016-04-25 14:53:55.521 CPBVOCA === View is configure ===

2016-04-25 14:53:55.573 CPBVOCA === LicenseKey is configure ===

2016-04-25 14:53:55.574 CPBVOCA === URL loading ===

2016-04-25 14:53:55.589 CPBVOCA navigation: original URL: 'file:///var/containers/Bundle/Application/5DC70087-3AC0-4F20-9DC2-48900F5AF2DD/' - final URL: '(null)' - isLoading: '1' - wasInterrupted: '0'

2016-04-25 14:53:55.590 CPBVOCA Observer is configure

2016-04-25 14:53:55.590 CPBVOCA Subview is configure

2016-04-25 14:53:55.640 CPBVOCA Wikitude is Running - 0

2016-04-25 14:53:55.640 CPBVOCA Try to start wikitude sdk


2016-04-25 14:53:55.875 CPBVOCA Result is configure

Hi Jeffrey,
Wikitude is Running - 0 doesn't look that good. Can you please also log the error object that is given in case the SDK could not start correctly.

Best regards


Login or Signup to post a comment