Start a new topic

3D Model not showing up in App

3D Model not showing up in App

Hey folks, small issue with 3D models we've exported to the .wt3 format. They export to FBX from 3DS Max and into the Wikitude 3D encoder just fine. But even without errors, we cannot get the objects to display in the AR app, no matter how simple the object. Whereas the default red car supplied with the SDK works instantly. We have tried various sizes for the object -- both in-app and in 3DS Max, putting it on the grid, removing animations and changing the .png texture in max to a .jpg. All for naught. And I cannot dissect what the difference is between the car.wt3 and our objects.

Anyone got a clue?

Which version of the 3dEncoder and the SDK are you using?

Can you provide the 3D model (fbx and/or wt3)?

We are using the latest version of the iOS SDK and encoder version 1.4

And as far as .fbx's go, we've had trouble with everything I could supply and one that we downloaded from the web as a test. I've supplied the simplest .fbx, its texture and a .wt3 of the same.

I tested the wt3 you provided on an iPad2 and Android (arm8): It rendered fine with a scaling of 0.05. (I replaced the car.wt3 of the SDK examples with your wt3.)

On which devices are you encountering problems?

We're finding them on an iPad Air and an iPhone 6, so we're checking if there's a problem with the code right now. Will keep you posted.

Make sure that the wt3 files are in the right place and that they are available for the app on the device. For the latter you have to add the file to the Xcode project (to the assets folder).

Also make sure that the AR world has no JS errors: Open the device debugger on Safari, choose the running app and reloud the html/js code.


I added our wt3 next to the car.wt3 in the SDKexamples 3_3dModels_2_AppearingAnimation/assets folder and changed 1 line of code in the appearinganimations.js(28): this.modelCar = new AR.Model("assets/Cube4D.wt3", {

And all it does is start the example and the "loadingMessage" keeps displaying "Loading..."

When I go to Safari and view and reload the index.html I see no js errors.

What am I doing wrong? Or what did you do different?

kind regards,




Does it work with the 3dModelOnTarget example (3_3dModels_1_3dModelOnTarget/js/3dmodelontarget.js)?

Does Cube4D.wt3 file appear in the Xcode Project navigator? If not, add it via "Add files to "assets"" in the context menu.
That the "Loading ..." message does not dissappear indicates that the wt3 actually never gets loaded. 

The "appearing animation" example uses a property animation for the scale. So you cannot set the scale directly, but have to make sure that the final state of scaling is around 0.05. So I would recommend to try the more basic example, mentioned above, first.

Hi Roland,

Yes, the wt3 file is visible in the project navigator.

And when I try the 3D Model on Target example gives the same result...

kind regards,

With none of the tips and ideas we got working, we decided to try a leftfield idea and completely re-download the SDK. And now it works. Thanks anyway for your help Roland.
Login or Signup to post a comment