Start a new topic

WTArchitectView behaves oddly on device rotation

WTArchitectView behaves oddly on device rotation

Hi there,

I am facing problem with the rotation of device on iOS when displaying a WTArchitect View using the latest iOS JS library. 

More precise, it happens when rotating from a landscape to a portrait orientation. 

In the first picture, you can see the landscape view as it is expected, in the second one, the portait view with a streched radar. Also when I am clicking on the info button, the popup appears about in the middle of the screen. 

In a previous version of my app, I used the ArchitectView in a Navigation Controller using a push segue. In this configuration, everything is fine, but than I had to use a modal segue and now, I have this problem. 

Further, I am setting up the WTArchitect View in the storyboard with "Equal Width and Height" and "Horziontally and Vertically Centered" to the super view. For this WTArchitect View I am using a weak pointer in my viewcontroller.h.  But I have also tried your setup as suggested in the iOS setup guide with a ArchitectView which is initiallized by code, but the same problem remains there.

My rotation related code is :

- (BOOL)shouldAutorotate {


    return YES;



- (NSUInteger)supportedInterfaceOrientations {


    return UIInterfaceOrientationMaskAll;



- (void)willRotateToInterfaceOrientation:(UIInterfaceOrientation)toInterfaceOrientation duration:(NSTimeInterval)duration {






I hope, you can help me. 


Many thanks,



EDIT: I was able to reproduce this behavior in your sample app by simply changing the segue to the ARView from push to modal. Than you can use for example the Adding Radar example.


Hi Benjamin,
Thx for pointing this out! We will definetly have a look at it. I just created an internal bug report for this.

Best regards

Login or Signup to post a comment