Start a new topic

GeoObjects Problem

GeoObjects Problem



I'm trying to develop an application that has 2 special AR.GeoObjects (the start point and the end point) and N extra AR.GeoObjects that are intermediate points between the start and the end. I think that i developed all the architectworld correctly and It shows 32 AR.GeoObjects in my iPhone 6, but the problem is that everytime that I close the App (pressing the Home button) and I start it again, all the points seems to be moved 45? degrees. This is normal because I've got a function that reloads all the points everytime that the App becomes active, but the problem is that this issue is happenning me all the time even when I start the app for the first time.


I don't know if I have to initialize the compass position or anything else before to present the architect world.


I'm using wikitude for iOS 5.1.1 and an iphone 6 with iOS 9.2.1.


I attach a video so you can see what is the issue that i'm having:


Thanks for your help!

Hi Raúl,
The behaviour you describe is because of a bug in our Geo part of the SDK. A fix will go live within the next few days, so please subscribe to our newsletter to get notified once the new version is available.

Best regards


Hi Andreas,

Thanks for your answer. I hope that the fix will be released soon ;)

Best regards!



I have exactly the same problem from since a year ago. They never corrected. I thought that with the sdk 5 would be corrected, but no. I checked in ios 8 and 9. iPhone 4, 5, and ipad2 and always the same.

For this reason my client did not allow the application to launch in stores.

I would like to solve this problem, and appreciate it correct to buy the license!


Really they believe they're going to correct?




Hi Raúl,
I just had a look at your report again and have some questions.
I tried our latest example application and launched the sample `Obtain Poi data - from local resource`. I changed line 106 from 



World.loadPoisFromJsonData(myJsonData); (I did this to make sure pois are not rearranged)

After that I launched the example and put the app in background/foreground a couple of times. For me the pois stayed at the same place.

Can you give us some more insights about your architect world or even send us a demo project where we can reproduce the issue?


Best regards


Good morning Andreas!!


Thanks for your answer, you can download my example project from here:


Best regards,

Hi Raúl,
I had a first look at your project and this is my initial response:

* I had to use parseFloat() to use the jsonResult correctly. Otherwise the Wikitude SDK gave me an error that it is not able to use the given input values (poiatlocation.js line 22,23,64).
* I replaced your poi data with some location values that work for me.

After that I got all pois rendered on top of each other. I'm not sure how it looks like for you or if this is expected. 

However, when I have a look at the position of this poi group, it stays at the same position, even if i put the app into background and foreground multiple times.

How should we proceed? Do you want to update the project so that pois are distributed more evenly throughout the scene? I assume that you have the initial problem with this project as well. I simply don't understand why it doesn't behave the same for me. Which version of the Wikitude SDK do you use?

Best regards


Hello Andreas,


The point should looks as you can see in the video of the first post. I'm not having any problem with the render of the pois, I'm just having the issue that their position is diferent each time that I put the app in background. I'm going to use parseFloat() to try if it fixes my problem!


best regards,

Hello Again!


I tried to use parseFloat and nothing changes, i'm having the same issue :S

Hi Raúl,
parseFloat shouldnt fix the issue but make the demo project work.
Anyways, are you still using version 5.1.1 of our SDK? Can you pleae try to use 5.1.2?

Best regards


Good morning Andreas,


I just updated the framework and It seems that It works better, but i'm having a new issue becuase when I run the application, a screen flashes telling me that I should calibrate the sensors. This screens just appears and disappears for 20 - 30 seconds, then It stops flashing and the POIs appears.


Should I change something?


Thanks and best regards!


I can manually override the sdk for the cordova plugin?


Hi Mateo,
You would need to do the following:

* rename the file WikitudeSDK inside the WikitudeSDK.framework folder to libWikitudeSDK.a
* extract the device architectures and simulator devices out of the static lib using lipo. `lipo libWikitudeSDK.a -thin arm64 -output libWikitudeSDK_arm64.a`
* create a static library which contains only the simulator architectures and one which only contains the device architectures
* replace the new static libraries with the existing ones


We will update our cordova plugin withing the next days, just in case you don't want to do the conversion manually.

Best regards


Hi Raúl,
It's good to here that 5.1.2 fixes the orientation issue. We currently investigate into the compass calibration issue, but it seems that it's an iOS 9 issue where we would need to work around this behaviour. I'm currently investigating this.

Best regards

Login or Signup to post a comment