Start a new topic

Crash on Android - failed: dlopen failed: cannot locate symbol "__exidx_en

Crash on Android - failed: dlopen failed: cannot locate symbol "__exidx_en


HI,

Also in my case, the application crashes exactly in the same way.

I've created a new workspace, done the update of  Appcelerator SDK and then made the import exactly as written here: http://www.wikitude.com/external/doc/documentation/latest/titanium/setupguidetitaniumandroid.html

I'm running on a wiko fever device. I've done the downgrade of the Android SDK. I was with 5.2.0 and I moved to 5.0.0 because the application was deployed for this version.

Any suggestions? 

Regards

 

For being more precise these are my errors: 

:  art: dlopen("/data/app/com.wikitude.titaniumsample-2/lib/arm/libcom.wikitude.ti.so", RTLD_LAZY) failed: dlopen failed: cannot locate symbol "__exidx_end" referenced by "libcom.wikitude.ti.so"...

:  TiApplication: (KrollRuntimeThread) Sending event: exception on thread: KrollRuntimeThread msg:java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__exidx_end" referenced by "libcom.wikitude.ti.so"...; Titanium 5.2.0,2016/02/20 08:05,384775e

:  TiApplication: java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__exidx_end" referenced by "libcom.wikitude.ti.so"...

:  TiApplication: at java.lang.Runtime.loadLibrary(Runtime.java:371)

:  TiApplication: at java.lang.System.loadLibrary(System.java:988)

:  TiApplication: at org.appcelerator.kroll.runtime.v8.V8Runtime.loadExternalModules(V8Runtime.java:132)

:  TiApplication: at org.appcelerator.kroll.runtime.v8.V8Runtime.initRuntime(V8Runtime.java:99)

:  TiApplication: at org.appcelerator.kroll.KrollRuntime.doInit(KrollRuntime.java:205)

:  TiApplication: at org.appcelerator.kroll.KrollRuntime$KrollRuntimeThread.run(KrollRuntime.java:114)

:  AndroidRuntime: FATAL EXCEPTION: KrollRuntimeThread

:  AndroidRuntime: Process: com.wikitude.titaniumsample, PID: 26481

:  AndroidRuntime: java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__exidx_end" referenced by "libcom.wikitude.ti.so"...

:  AndroidRuntime: at java.lang.Runtime.loadLibrary(Runtime.java:371)

:  AndroidRuntime: at java.lang.System.loadLibrary(System.java:988)

:  AndroidRuntime: at org.appcelerator.kroll.runtime.v8.V8Runtime.loadExternalModules(V8Runtime.java:132)

:  AndroidRuntime: at org.appcelerator.kroll.runtime.v8.V8Runtime.initRuntime(V8Runtime.java:99)

:  AndroidRuntime: at org.appcelerator.kroll.KrollRuntime.doInit(KrollRuntime.java:205)

:  AndroidRuntime: at org.appcelerator.kroll.KrollRuntime$KrollRuntimeThread.run(KrollRuntime.java:114)

 

I hate to say this.. but I paid 5K Euros for a 12 month Enterprise license and they have not put a priority on fixing this issue and effectively all our android apps can not benefit from Wikitude module.  I have been in weekly and at sometimes daily communiation asking (begging) for them to fix this.  I was once told it would be fixed by March 1 but still nothing.

 I emailed the CEO which I did get a response but it was quite clear he or someone in his team did not clearly communicate because we referenced iOS in his email.  I am very regretful for ever recommending Wikitude for Titanium use because it has cost us a customer.

 I have never purchased the top level software license from a company and recieved such 2nd class citizen support.

 

 

Hi Will, 

thanks for reply. I'm pleased to see an answer. Which kind of Wikitude SDK for Android have you tested? 

I've downloaded from here the JAVASCRIPT API Version 5.1.4 (298.8 MB): WikitudeSDK_Android_5-1-4_2016-03-14_14-50-48.zip 

Are you using Appcelerator too? 

At the moment, I'm trying to study the sample code for seeing if I manage to start short easy-to-read code.

In other words I was wondering to so something like this: 

//1. set the license key

var WikitudeLicenseKey = "MY LICENSE KEY";

 

//2. import the famous ARchitectWindow -> here it is said that this fil should be used to create and launch an "ARchitect World"

var ARchitectWindow = require('/ui/windows/ARchitectWindow');

 

//3. set these variables: i've seen in /ui/windows/ModelStorage.js for the expected values

var url2launch = "path_to_index_html.hml";

var requiredFeatures = ;

var startupConfiguration = {"camera_position": "back"};

 

//4. launch the World in this way (i've seen in /ui/windows/SampleListWindow.js)

var architectWindow = new ARchitectWindow(WikitudeLicenseKey);

 

if (architectWindow.isDeviceSupported(requiredFeatures)) {

architectWindow.loadArchitectWorldFromURL(url2launch, requiredFeatures, startupConfiguration);

architectWindow.open();

} else {

alert('not supported');

}

 

I was thinking to try something like this launching one of the sample-code in a new clean project.

Have you already made any trial like this?

I let you know how it goes.

Hope to hear from you.

Kind Regards.

No way. I got exactly the same error! 

After that I've done another attempt: I've created an empty project with Titanium SDK 5.0.0.GA and let it as it was. Then I've only added com.wikitude.ti and ... I got exactly the same error. 

So unfortunately I arrive to your same conclusion... 

I've seen here that someone managed to run it with older version of titanium ... I tried to downgrade to 4.1.0 but the run failed... but this way could be further investigated. Have you done any effort in this direction?

Hope to receive some help from someone. Thanks in advance. 

Hi Chiara,
We're about to update the Titanium Module but it still takes us a couple of weeks to do so. We let you know once we have updated our Module to use the latest SDK and Appcelerator Studio version.

Best regards

Andreas

 

10-26 11:57:12.954: D/dalvikvm(17516): Trying to load lib /data/app-lib/net.totallytourist.where2gosavlocal-1/libcom.wikitude.ti.so 0x4208af38

10-26 11:57:12.954: E/dalvikvm(17516): dlopen("/data/app-lib/net.totallytourist.where2gosavlocal-1/libcom.wikitude.ti.so") failed: dlopen failed: cannot locate symbol "__exidx_end" referenced by "libcom.wikitude.ti.so"...

10-26 11:57:12.954: W/dalvikvm(17516): threadid=10: thread exiting with uncaught exception (group=0x41721da0)

10-26 11:57:12.954: E/TiApplication(17516):

 

We have the same code base working fine with iOS.  However our app crashes immediately open opening with this.

 

Thanks

Hi Will,
Can you send us more information about: your device (type, Android version) and the version of the Titanium Module/Wikitude SDK you're using? THX!

Best regards

Andreas
Login or Signup to post a comment