Start a new topic

Error : Library libarchitect.so not find

Error : Library libarchitect.so not find


Hi,

I am using Wikitude vuzix SDK, and I have the same error. Did you find a solution ?

I have already tried differents way (rename the file "libs" by lib in the wikitudesdk.jar, extract the libarchitect.so of the .jar file and imported it alone...) but none of it work.

Thanks,

Lucille Saadé

Hi Lucille,
Did you try to convert the example application to Android Studio or do you use Eclipse?

Best regards

Andreas

Hi,

I try to convert the example application to android studio and I try to create an application with juste an architectView directly with android studio.

Lucille Saadé. 

Hi Lucille,
I answered in the second thread where you are also talking about this issue. Let's keep our conversation in the other one.

THX

Andreas

Sorry, It was just in case Sohleil found a solution for himself.

Thanks for your answer,

Lucille Saadé.

Configuration

Android Studio 1.5

Target SDK Version : 23

Min SDK Version : 11

 

Hello,

When I launch my Activity which use Wikitude SDK, I get this error on my stackrace :

dlopen("/data/data/mypackage/libarchitect.so", RTLD_LAZY) failed: dlopen failed: library "/data/data/mypackage/libarchitect.so" not found

java.lang.RuntimeException: Unable to start activity ComponentInfo{ARZMTActivity}: android.view.InflateException: Binary XML file line #5: Error inflating class com.wikitude.architect.ArchitectView

 


Would you have a solution to correct this problem? Thanks you for your help.

Hi there!

Please have a look at the sample project and see if issue is solved when importing and deploying it.
I guess you didn't include the library properly - Check out getting started guide for more details.

Best regards

HI,

I am using Wikitude Vuzix sdk which runs on version 4.x and I am running to similar Error for libarchitect.so when trying to run the project on android studio 1.5.  SDK sample that wikitude has provided works fine in eclipse, but I dont like to work on eclipse xml project! I tried first auto import from eclipse to android studio as well but that didnt help So I made a gradle project from scratch and configured everything using sample example.  Compilation is successful but when launching mainactivity intent I am getting following main exception :

"failed: dlopen failed: library "/data/data/.../libarchitect.so" not found"

 "android.view.InflateException: Binary XML file line #15: Error inflating class com.wikitude.architect.ArchitectView" .

This error is known to the community(stackoverflow,etc) , people are suggesting different ways to solve the issue(unzip wikitudesdk.jar , make jniLibs folder and copy opencv, etc. ) but for me none of it worked. Please help by giving a solution! (if exists!).

Thx

Cheers

Soheil

 

Update your Wikitude SDK by the latest verstion (5.1) and configure your gradle file like this : http://www.wikitude.com/external/doc/documentation/latest/android/setupguideandroid.html#setup-guide-android

Hi thx for your reply, The solution you have proposed unfortunately is not working in my case. Because the latest Wikitude sdk version for Vuzix glasses is 4.x!   
Login or Signup to post a comment