Start a new topic

Phonegap Wikitude Plugin Sample App doesn't work

Phonegap Wikitude Plugin Sample App doesn't work

I've successfully installed wikitude plugin in Cordova for evaluation purposes. I've downloaded your sample and followed your instructions for manual installation (Sorry but your .sh scripts doesn't work on windows). The app seems to work but I don't understand what is WORLD URL (???) and when I try to launch some modules, the app doesn't respond.


World is a term for the AR experience - so you can load your AR experience with loadARchiectWorld. So whenever you see this term it's a synonym for the complete AR experience.



Hi Nicola,

Thank you for the explanation, but I still can't run you sample app.. In order to have the app working I need to insert a WORL URL? And what kind of url is this? The app seems blocked. When I click on the app links, the app doesn't respond. Maybe I'm missing something...



If you're trying to run the sample app, please follow the steps here.

This should do already everything you need and load the proper 'Worlds'. If you implement this functionality on your own, you'll need to reference the .html file of your 'World'. For this also please check the documentation and the sample app.



Hi, Paolo


I got the same problem on my Android platform.

And I also find CreateSampleApp.cmd doesn't work on Windows.

So my workaround is "Creating an Empty New App" followed by "Adding Samples Manually to Your App".


Have you solved the problem? If so, how did you run the samples successfully?

Same problem.


Any answers?



Hi, I'm experiencing the same behaviour. On one hand the .sh script doesn't work on Mac either. So I added manually the files to my project as the article suggested. I build it correctly and installed the APK in my Android phone. I can launch the app and I can enter the World URL. But I can't open none of the other links. None of them responds in any way. What am I missing please?

I just imported the android project to Android Studio. I ran the app from there so I can see the log of what is happening. The problem es with the following line in the index.js file:

if ( example.path.length > cordova.file.applicationDirectory ) {

 cordova.file is undefined. I checked and cordova is initialized but cordova.file is not. I haven't made any modifications to the downloaded project. Please help.

I had to add the cordova-plugin-file manually to the project. Then it worked.

Login or Signup to post a comment