Start a new topic

3D encoder only displays black windows

3D encoder only displays black windows


I am testing the wikitude SDK, and I need to embed some 3d models in a test app. To do so, I downloaded the wikitude 3d encoder, and installed it on a windows 7 (32 bits) PC (by double clikcing the setup.exe file, as said in the online docs). The installation is fine, and when I start the program, a new window is opened, but  eventough the window title is "Wikitude 3d Encoder" and has the wikitude logo, the window content stays black (I attach a screenshot). I've tried to restart the computer after installing with the same result. I tried it in two different PCs with the same SO and also on a VirtualBox running the same SO on a Lubuntu guest.

Am I doing something wrong?

Thanks in advance,



If you uninstalled all oder versions of the Wikitude3dEncoder and started the installation via setup.exe you did everything right. 

Question: If you move/resize the app window, does the window content appear temporarily?

Maybe updating the driver of your graphics card solves the problem.

Hello Roland,

If I move, minimize and maximize, or set the window fullscreen, there is no change, the window content is still black.

The driver seems to me up to date, there is no problem reported in the device admin. I will check with sysadmin.

I've tried in another PC which is Windows 7 Home Premium 64bits, and then the application crashes. The detalis are (labels are in catalan):

Signatura del problema:

  Nom de la incid?ncia del problema: APPCRASH

  Nom de l'aplicació: Wikitude3dEncoder.exe

  Versió de l'aplicació:

  Marca hor?ria de l'aplicació: 55de7270

  Nom del m?dul amb errors: ig4icd32.dll

  Versió del m?dul amb errors:

  Marca hor?ria del m?dul amb errors: 4da8816d

  Codi d'excepció: c0000005

  Desplaçament de l'excepció: 00012dc4

  Versió del sistema operatiu: 6.1.7601.

  Identificador dels par?metres regionals: 1027

  Informació addicional 1: 0a9e

  Informació addicional 2: 0a9e372d3b4ad19135b953a78882e789

  Informació addicional 3: 0a9e

  Informació addicional 4: 0a9e372d3b4ad19135b953a78882e789


Llegiu la nostra declaració de privadesa en línia:


Si la declaració de privadesa en línia no est? disponible, llegiu la nostra declaració de privadesa fora de línia:




What graphics card do you have in your PCs?

Sorry for the delay, I've been busy the last two weeks.

In one of the PCs, the graphics card is "Intel (R) Graphics adapter". In the other is "VGA standard adapter". In the VirtualBox the graphics card is an Nvidia G105M, but as the windows7 is running in as the guest OS, I think the Windows7 and wikitude 3d encoder has no direct access to the GPU.

Which graphics card are supported? Is ther any workaround?
We managed to make it work in pcs with nvidia gforce 210 (tough similar pcs with the same video card have the same problem, we are trying updating the drivers on those).
Then we are facing another problem. The thing is that we convert an fbx model to wt3, but we made the project with the 4.1 sdk. When loading the wt3 in an AR.Model, the console log says the file has an incorrect version number and the file is corrupted.
Is there a way to generate wt3 files for the sdk 4.1?
We are using this version because the 5.1 samples do not work in some devices we test.


You can create .wt3 for the SDK 4.1 by using the Wikitude3dEncoder which is contained in that SDK package. 

However, I would recommend to point out the problems you face using the SDK 5.1 and make this work.

On which devices do you have problem with SDK 5.1?

What do you mean by "the 5.1 samples do not work" ? 

I happen the same thing, after installing for the first time the 3D encoder software appears a black screen with the word as per attached picture

how can I do to fix? My notebook has S.O. win 10, graphics card intel 965 express as per attached picture

The CPU is a dual core 2 duo with 2 GHz and 4GB ram

how can I do to fix it?

Did you install the encoder via the setup.exe file? 

You should not directly install the .msi file. 

yes, i've install setup.exe file

Actually the Wikitude3dEncoder should not load this .dll. So I'm wondering why this message comes up at all.

It seems like you have some Qt* libraries on your machine which are used instead of those bundled with the encoder in the bin sub-folder. 

Therefore I would kindly ask you to (1) completly remove the encoder by uninstalling it via the Windows->Settings->System->Apps, (2) delete any .msi or setup.exe instances from your download folder, (3) download the encoder again from our download page and (4) install it again via setup.exe.

If the problem then still exists you can have a look into your PATH environment variable and remove all directories which contain Qt* dll's.
Login or Signup to post a comment