Start a new topic

Non public API usage, SDK 5 Cordova plugin

Non public API usage, SDK 5 Cordova plugin


Anybody? It's crucial that we can submit this app.

Hi,

We're fixing this now, but if it's urgent you can try the following:

Please download the latest iOS SDK from here. Copy the file ?WikitudeSDK? from the WikitudeSDK.framework and put it in the folder where your current phonegap plugin is  located (libWikitude.a) and rename it to ?libWikitudeSDK.a?. Additionally please copy the header file ?WTArchitectView.h? from the 'WikitudeSDK.framework/Headers? folder in the Wikitude PhoneGap Plugin folder.

Greetings

Nicola

Hi Nicola,

Thanks for letting me know a suitable fix for the time being - I can confirm your solution works and we have been able to submit to the app store.

Best Regards,

Paul.

Hi Paul,

Great that it worked. Should you need anything further, just let me know anytime.

Greetings

Nicola

Hi,

Im too receiving the non public API usage issue as already reported here, although we are using the cordova plugin as per your documentation. How do we download the correct SDK using the cordova plugin?

Kind Regards,

Paul.

I have the same problem, please provide us with a fix like you did for the IOS SDK

I would just like to add that this issue gets picked up by iTunes connect and does not allow app builds to be submitted to the app store.
Login or Signup to post a comment