Start a new topic

IOS Crashing app

IOS Crashing app


Everything is working fine in my application. But when I am going back and again entering into ARView my app is getting crashed with following errors.


Check failed: !IsGoogleLoggingInitialized() You called InitGoogleLogging() twice!

*** Check failure stack trace: ***

    @   0x137e59  google::LogMessage::Flush()

    @   0x138c3d  google::LogMessageFatal::~LogMessageFatal()

    @   0x138109  google::SendEmailInternal()

    @   0x13ccd1  google::glog_internal_namespace_::InitGoogleLoggingUtilities()

    @   0x25282b  wikitude::common_library::impl::iOSConsoleWriter::iOSConsoleWriter()

    @    0xb0ac1  -

    @    0xad0ad  -

    @    0xacf51  -

    @    0x628a3  -

    @ 0x2eea1f8f  <redacted>

    @ 0x2eea1cfd  <redacted>

    @ 0x2f02afd9  <redacted>

    @ 0x2ef4aee7  <redacted>

    @ 0x2ef4aced  <redacted>

    @ 0x2ef4ac81  <redacted>

    @ 0x2ee9f4d7  <redacted>

    @ 0x2e8c7a0d  <redacted>

    @ 0x2e8c33e5  <redacted>

    @ 0x2e8c326d  <redacted>

    @ 0x2e8c2c51  <redacted>

    @ 0x2e8c2a55  <redacted>

    @ 0x2e8bc92d  <redacted>

    @ 0x2b9a93b5  <redacted>

    @ 0x2b9a6a73  <redacted>

    @ 0x2b9a6e7b  <redacted>

    @ 0x2b8f5211  CFRunLoopRunSpecific

    @ 0x2b8f5023  CFRunLoopRunInMode

    @ 0x32cc50a9  GSEventRunModal

    @ 0x2ef011d1  UIApplicationMain

    @    0x4a4fd  main

    @ 0x39a0baaf  <redacted>


-Which SDK version are you using - the official version 5?

-Are you working with the Native or JS API

- What are your OS version and test device model.

- is this happening in your own app or in the sample app

The issue sounds like it has something to do with Google logging 'Check failed: !IsGoogleLoggingInitialized() You called InitGoogleLogging() twice!'. Can you  check your code for the google logging.




I am using Official SDK version 5, And using JS API.

OS Version is 8.1. in my ipad.

This is happening in my own app.

I have checked it in my code and I never used InitGoogleLogging().


Hi Boggarapu,
The problem here is, that you allocate a new object of type `WTArchitectView` when there is already one active or the previous one was never deallocated. Please verify that your previous WTArchitectView object is deallocated when you create a new one.

Best regards


Hi Andreas,

Even though I have deallocated the previous object by using ;    I am getting again the same error.



The Wikitude SDK does not offer a method called 'stopWikitudeSDKRendering'. This method also does not deallocate the object. To deallocate the object, you need to set the WikitudeNativeSDK pointer to nil.

Best regards


hi, i am having same problem after updating Wikitude framework file to iOS_5_0_0 from iOS_4_1_1. 


i am also not using Google Logging library or samething like that. Like i said this error happens only after upgrading wikitude sdk 5. 

And i don't understand how to deallocate WikitudeNativeSDK pointer.
"To deallocate the object, you need to set the WikitudeNativeSDK pointer to nil." how can i manage to do that? 


i am using multiple architectView on 4 different viewcontroller. and this error happens when switching from each other.  My each architectView serves differant roles like location and target image based. 

this is how declare architectView


NSError *deviceSupportError = nil;

if ( ) {

self.architectView.delegate = self;

//NSLog(@"WTArchitectView.sdkVersion %@", WTArchitectView.sdkVersion);


self.architectWorldNavigation = ;



}else {

NSLog(@"This device is not supported. Show either an alert or use this class method even before presenting the view controller that manages the WTArchitectView. Error: %@", );





any help appreciated.




I am getting the same error message. How do I deallocate WikitudeNativeSDK?

I am having the same issues. Can anyone be of help?

I have exactely the same problem since i migrate to wikitude 5.

Hope somebody can help us.

same here ... push

I may have found a solution for this.

Some feedback would be nice.

The same for Xamarin. 
I didn't have any observers, just 

architectView = new Wikitude.Architect.WTArchitectView();

And add to subview.

So, when controller closes, i'm removing from subview and it seems it still not deallocates.
Login or Signup to post a comment