Start a new topic

Some models crashing after wikitude 5.0 update

Some models crashing after wikitude 5.0 update

1 person has this problem


After updating to the Wikitude 5.0 SDK, some 3D models seem to be crashing the SDK. The models that I use worked fine with Wikitude SDK 4.1. Whenever the 3D model should appear on screen, the application crashes. Sometimes it simply freezes, but most of the time I get the following error:

1144-1487/com.wikitude.sdksamples E/chromium? ### WebView Version 44.0.2403.90 (code 240309050)

1144-1487/com.wikitude.sdksamples A/libc? Fatal signal 11 (SIGSEGV), code 1, fault addr 0x8 in tid 1487 (GLThread 4193)


The models that crash the application are quite large (ranging from 10 000 vertexes to 1.1mil vertexes). 

I tried converting the models multiple times with the 3D encoder from both .fbx and .dae formats, but neither of these fixed the issue. I have also tested with multiple devices (NVidia Shield, HTC Nexus and some smart phones) Was there some large change to the way the SDK views the 3D models, and are there going to be any patches in the future regarding the viewing of 3D models? 


Best regards,


Hi Mikko,

can you please send us the 3d models (both wt3 and fbx) causing the problems?


I am not able to send you the actual model I am using due to NDA, but I created a "wireframed" model which causes the same issue. I also tried to add the model to the "3D object on target" example to see that the issue was not in my own code, but the model also crashed the sample program. When I use the model in SDK version 4.1 it works fine.

Wt3 file:

Fbx file:

I confirm the crash of the SDK. It's related to the point light source. 

We have a major update of the 3d rendering in the SDK 5.0. We will fix the problem. Thanks, for providing the 3d models.

I will come back to you. The fix will be included in the next pre-release of the SDK 5.0.

This issue is resolved and will be part of the SDK 5.0 release scheduled for next Monday.

Crash is still happening in my app, for various 3D models.

Is there any solution for this?

I tested the 3D model provided in the link above. It was loaded and rendered with the SDK 5.0 without problems. 

If you have other 3D models which cause problems, please send them to us so that we can have a look.
Login or Signup to post a comment