Start a new topic

Sample app not working

Sample app not working


Hi all,

I am green in wikitude, please help.

I follow all step in the setup guide, everything seem to be good, but I can click any of the links to let me try the sample.

What wrong with this? I got not error message. Trial License had be installed. 

thank you


did you deploy to a physical device? because it will not work with emulators.

Hi Ross,
You can use Safari Web Inspector in combination with an iOS device to see what kind of error occured in JS.

Best regards

Andreas

I ran into the same problem as Ross. 

Including the trial license key in WikitudePlugin.js seems to stop cordova's deviceready from firing.

Funny thing is replacing the license key with "ENTER-YOUR-KEY-HERE" doesn't undo the problem.

The links work fine before including the license key (they lead to worlds with the license key missing image).

I'm running the app on Samsung Galaxy Tab 3 Lite.

Any suggestions on how to get wikitude working?

 

Hi,

Can you please explain step-by-step what you did, where you enter the key and send over the trial key to forum wikitude.com.

Thx and greetings

Nicola

sent!

thought i'd include the contents here in case someone else has the same problem.

Steps I did:

First I downloaded the samples and ran the shell script successfully.

Second I ran the sample app on my device and it worked while showing the license key missing image.

Third I included the trial license key in line 12 of WikitudePlugin.js.

Fourth I ran the sample app again on my device and the links were broken. Did some debugging and realised that deviceready is never fired and app.wikitudePlugin never initialised.

Also tried creating a wikitude app by following "Using the Wikitude Plugin to create your own augmented reality experience" but again cordova?s deviceready failed to fire after I included the license key.

hope to hear from you soon!

solved the problem:

go to line 29 of WikitudePlugin.js and comment out the comment properly.

Somehow when license key is keyed in and the project run line 29 goes wonky.

Thanks Nicola for your replies :)

Are you use IOS9 for your test?

Hi Jose,
Did you tried our latest Cordova Plugin/Example App Update? It works fine with iOS 9.

Best regards

Andreas
Login or Signup to post a comment