Start a new topic

deviceready has not fired after 5 seconds

deviceready has not fired after 5 seconds

Hi guys!

I'm getting the following console messages when running the PhoneGap Samples through the PhoneGap Developer App on my Android tablet:

deviceready has not fired after 5 seconds
Channel not fired: onPluginReady
Channel not fired: onCordovaReady

I installed the samples using the "auto installer" on GitHub:
sh -d ~/Path/Where/The/App/Should/Be/Created -ios true -android true

I do get the "Wikitude Plugin" index.html to display, but clicking on the links don't work. Other than adding FireBug Lite, I haven't modified the code at all.

Oh, and the version of Cordova I'm running is:

cordova platform version android

Installed platforms: android 3.6.4

Available platforms: amazon-fireos, blackberry10, browser, firefoxos, ios

I got rid of:

<script type="text/javascript" src="cordova.js"></script>

And that got rid of the messages. But nothing happens still when I click on any of the links. Any ideas why? When I try to invoke the link manually (through Firebug) like so:

app.loadARchitectWorld(getSamplePath(1, 0))

I get:

Cannot call method 'setOnUrlInvokeCallback' of undefined

Does the sample application work if you don't add any external component?

The sample application has 2 different WebView: one is used by PhoneGap to run the main app code, and the other one is used internally by the ARchitectView to run the code in your AR world. Which one are you debugging?

I can't find any documentation about FireBug used in a PhoneGap application. We usually debug javascript code on android devices (android version at least 4.4) using chrome remote debug:


I still couldn't get it to work, though I'm not sure why. I ended up just using the native SDK and it worked so well it gave me goosebumps. Thanks!

I figured out the problem, it had to do with the fact that I was trying to run it through the Phonegap Developer App. When I run it through the command line, it works just fine. Any ideas why, or solutions to fix it?

Hi Oz,

from the errors you got it seems like the Wikitude plugin wasn't loaded when you ran the app through the Developer App.

There is no official support for the Developer App from our side right now, but we might look into it at some point.

Best regards,
Login or Signup to post a comment