Start a new topic

Official sample app doesn't show any poi.

Official sample app doesn't show any poi.

Hi! I'm building your Wikitude SDK v.4.0 example app with Xcode 6.0.1, in iPhone 5 with iOS 8.0. The camera view doesn't show any poi. I've also tried Wikitude SDK v.3.3.2 with the same results. I've got an app running Wikitude SDK 3.2.1 and it doesn't show any poi neither. 

So, basically, example app of Wikitude SDK 4.0 and SDK 3.3.2 doesn't display any poi in:

- Poi At Location

- Poi With Label

- Multiple Pois

- Selecting Pois

Do you have any ideas?

Hi Leonardo,
We're currently working on a new example applcation which should be available within the next days. 
Meanwhile you could try to add the new plist entry for location access (please refer to the releae notes from the developer channel sdk and apple regarding location access). The key you're interested in is:


<string>Accessing GPS information is needed to display POIs around your current location</string>


Best regards


Thank you, Andreas, for your answer. I tried as you've suggested but the issue is the same: no pois. 

While you keep working on a new sample application, I would like to use Wikitude 4.0 in my app. I do everything the documentation says but cannot see any pois. The watermark and Wikitude icon appears as well as other html elements I put but no pois. 

The console is showing this message: Wikitude SDK: ArchitectEngine: Can not project GeoLocation.

Any ideas?

I keep working in my app. Can't make it show the pois. 

But I see some strange behaviours:

- If I initialize AR with WTAugmentedRealityMode_IR, html content (no pois) is shown.

- If I initialize AR with WTAugmentedRealityMode_Both or WTAugmentedRealityMode_Geo, html content is not shown. 

- Before entering AR, if I enter in another viewController which calls requestAlwaysAuthorization from CLLocationManager, then html content (no pois) is shown in every mode (IR, Geo or both). 

Pois are actually loading because I was able to print a message in the statusMessage frame. In fact, when I'm able to load the html content, I can navigate through the pois and see their names displayed in the statusMessage; but I can't see them. The poi image is in the project so that is not the problem. 

Please, we need to fix the app as soon as possible. 

Best Regards,


Do you use the Wikitude SDK 4.0.2 from our developer channel release page? It is required for iOS 8 and gps access.

Best regards


Regarding the projection error log message. 
Can you make sure that you don't have interchanged latitude & longitude values while creating AR.GeoLocations?

Best regards


I've tried the Wikitude SDK 4.0.2 in my app and it doesn't work.

The sample app inside the SDK doesn't work. I added the NSLocationWhenInUseUsageDescription and NSLocationAlwaysUsageDescription entries in the info.plist of your sample application. Localization permissions are granted and pois are loaded but, as in my app, can't see any pois. 

I attached a screenshot FYI.

Thank you.

Hi Andreas, any update on this?

We are working with SDK 4.0.2, and simply running your sample app does not show any POI.

We need this working as we have more than 120 apps with wikitude and we can not compile with xcode 6 under iOS8. If you guys are working on this I would appreciate an estimated time of solution.

Thanks & regards

You need to enter a valid license key. You can create a free trial license key on our website. With the generated key you can try out all the functionality but with a 'Trial' watermark. Once you purchased a license the watermark disappears.

Please refer to our example applications how to use the license key.

Best regards


Thank you, Andreas. Setting the new trial license key made it work. 

Now, in my custom application, after allowing the app to use user localization, there are no pois. I quit the application, go to Settings > Privacy > Location Services and set my app setting to "Always". I enter my app again and AR works perfectly. Do you have any idea why this happens? It seems it works great with "Always" but I can't see any pois with "While Using". 

Thanks and best regards.

Nevermind, I've just fixed that. 


That's good news!

Please feel free to post all other question you have while working with the Wikitude SDK. 

FYI: We're about to release a public SDK 4.0.2 within the next days.


Best regards


Thank you for your support and suggestions!


Kind Regards.
Login or Signup to post a comment