Start a new topic

Multiple 3D Models with different Options

Multiple 3D Models with different Options

Hello everybody,

i started implementing a little augmented reality game using the wikitude skd for android.

What i want to do basically is to add multiple AR.Models of the same .wt3 file to the camera.

Here is my sourcecode:

//Create the tracker with the target collection

var carTracker = new AR.Tracker("assets/");


//Create a Trackable2DObject which should be tracker via the tracker

var trackable2DObject = new AR.Trackable2DObject(carTracker, "carAd");


var modelOptions = {

scale : {

x : 0.005,

y : 0.005,

z : 0.005


translate : {

x : 0.0,

y : 0.05,

z : 0.0


rotate : {

roll : -25


onClick : function() {

this.translate.y *= -1;




//Create a 3D Model with the given options

var enemy1 = new AR.Model("assets/enemy_blue.wt3", modelOptions);


//Add enemy1 to the camera



//Create a 3D Model with the modified options

var enemy2 = new AR.Model("assets/enemy_blue.wt3", modelOptions);

enemy2.translate.x = 0.01;


//Add enemy2 to the camera



If i just add enemy1 to the camera everything works as expected, and my 3D Model with the given options appears. But if want to add a second model of the same wt3 file with different options i get the following error (see attachments):

ArchitectWebView(19979): Corrupt wt3 file.

ArchitectWebView(19979): Preparing wt3 model failed.


What I'm doing wrong ?






I verified this with our latest SDK on Android using a local or remote World and both worked. Are you using our latest SDK?

If the probelm persits it might be a .wt3 specific problem. In that case would you be able to share the model? If you don't want to post it in the forum please email it to forum AT wikitude DOT com.

Checking a few other things:

- What device are you using? Did you try it on different devices?

- Have you tried deleting the app and trying again?




Hi Wolfgang,

thx for yout Answert !

Yes I'm using the latest SDK(3.3.1). I'm using the Nexus 5, at the moment I've no other device nearby. I've tried to delete the app and reinstall again.

See the Attachment for the .wt3 file


Thanks for your help,



Ps: I'm gonnga to try a different wt3 file now.


I tried it with an other .wt3 file (the car of your examples) and everything works fine.

Can you tell me where the problem with our .wt3 file is ?

I could reproduce it on our side with the attached 3D model. The issue seems to be specific to Android and this specifc model. I've filed a bug and we will investigate this further. However at the moment I can only suggest to either test on iOS or use a different 3D model. We will update this thread once we have more information.

Thanks for reporting the issue!

I'm having the same issue here.
Nexus 4
Android kitkat
and the model attached.

Hi, this has been fixed, and the fix will be availalbe in the next release.

As a temporary workaround you can wait for the "loaded" event of the first model before loading the other one.

Many thx to Gabriele for the answer !

Waiting while the previous model is loading, is a good workaround for this problem 

How can I achieve this beaviour?


Hi there,

have you scheduled the release already?


We are testing the next developer channel release internally, as soon as the tests are Ok, it will be available for download.
Login or Signup to post a comment