Start a new topic

Using Wikitude with API level BB 10.2

Using Wikitude with API level BB 10.2

I am developing an application using Wikitude SDK and BB API level 10.2 .The application fails to compile and execute on my deviceand give these errors:


make: *** Error 1
make: *** Error 2
make: *** Error 2



The application builts and runs succesfully when using API level 10.0 but I require 10.2.


Thank you

Same here.

Example project is giving me the same errors.

Knowing that Wikitude for BB10 is now Community Edition and has no support, makes me think SDK was working fine in early BB versions (10.0).

Any solution for 10.2 ?

This issue is caused due to the fact that BlackBerry from 10.2 is supporting libpng 1.6 instead of 1.4 required by Wikitude.

You can easily solve the issue by linking to libpng 1.4 or as an alternative use BlackBerry 10.2 beta api level which supports both 1.4 and 1.6

Thanks for you fast reply.

I´m going to test it.

Do you have any extra documentation?

Thanks again.

10.2 beta supports pretty much all api in 10.2 so the easiest way would be to just download the api level from within Momentics.
Login or Signup to post a comment