Start a new topic

Datasets tutorial is not opening

Datasets tutorial is not opening


I am just starting with Wikitude SDK and what I am learning from Wikitude tutorials is that first I need to learn how to create Datasets. I click on tutorial link and it does not open.

Has tutorial moved to a different address? 


Hi Sergey,

Pleaase have a look at this documentation section:

Our documentation section can now be found here.



Nicola, thank you very much for your message! 

I went through a few tutorials and the tools. I was able to run couple of examples and everything seems to be working well. I found and tried using the Target Management tool to create image collection and it looks like working. 


I have one more question. It looks like My ARchitect world is not loading. When I run my own project the "Loading..." from my World keeps on displaying and does not dissapear. I assume it is because I cannot load the .wtc file. I tried my own and I tried those from example projects. Still same issue. This is my project directory: 





Here is how I load the .wtc file (just like it is in Example projects and Tutorials)

this.tracker = new AR.Tracker("assets/", {

onLoaded: this.worldLoaded



Can you help me figure out why "Loading..." keeps on showing or why the .wtc file cannot be loaded?

Thank you!



Hi Sergey,

First please make sure the all the samples are running without any changes. Once the IR samples are running you should be able to change the .wtc file and the needed references in your code.



Nicola, thank you very much for your reply. 

Yes, I am able to run Image Recognition example called Image on target. It runs well and it does recognie the image. However when I try it on my project. The Loading... keeps on showing and does not dissapear. 

 Tried draggin and droping the .wtc file to my project. Tried adding files through Xcode menu. Tried creating new collections nothing helps :(. What do you think can be the problem?




Also I have noticed that any changes that I do to css/Default.css do not effect the Loading label on Camera view. 
I changed: 

top: 100;
left: 100;

also background color but it has no effect on:

<div id="loadingMessage" class="info">Loading ...</div>



Nicola, also I have noticed that any changes I make in imagerecognition.js have no effect :(. Something is definetly wrong. This time I added files by dragging and droping them into my project. I can see and javascript file in Build Phases -> Copy bundle resources... 



I am guessing you are using iOS and XCode. If that is the case, make sure to use a folder reference (blue folder icon) when adding the asset files to your project.

Wolfgan, thank you very much for your response. It looked and worked very wiered as you can see from the description above. I did make sure I add references yes... What I did to fix the problem I simply deleted that example project and created a new one and repeated all teh steps again. It worked perfect. I then did that again and again and it just worked very well. I could not reproduce the issue... I have my example project working very well. It recognizes images and displays different types of overlays.
Login or Signup to post a comment