Start a new topic

Radar/Pois look stuck

Radar/Pois look stuck


Hi,
The last SDK update included various fixes that affect the rendering.
When you experience some issues, please send us a project which demonstrates the problem so that we can have a look at it. Simply send the project to: ios-sdk@wikitude.com

Best regards
Andreas

Hi,

This issue seems related to a similar issue we are currently experiencing. Our iOS app has the functionality to add a photo on another view controller. However, once you return to the AR view after a photo was captured, the camera view seems to have frozen/lock at the last view. The POIs are still being plotted, can be updated and selected as normal on in the Architect view but the actual background camera view is not moving.

I don't see any mention of this issue being fixed in the latest release notes. Could you please give an update regarding this, and possible fixes.

Running the latest 3.2.1 SDK.

Thank you.

 

Hi,

since multiple user reported a similar issue, we're currently investigating it and release a maintenance update as soon as we could fix the issue.

 

Best regards

Andreas

In our iOS app, we have a functionality to add new objects to the AR view by adding a photo. It was working alrite, but for some days now, after a new object is added, when we return to the AR view, the view looks stuck. Sometimes the radar is stuck and it won't move while the camera moves around. Sometimes its the other way round. And sometimes the AR view background just goes black, and the objects are visible. This happens regularly in iPhone 4 and iPhone 4S and intermittently in iPhone 5.

In all devices, intermittently a crash occurs - 

* thread #63: tid = 0x4519c, 0x00249710 <App-name>`Core3D::BillboardManager::draw(PVRTMat4 const&, bool, float) + 148, queue = 'com.wikitude.architect.renderqueue, stop reason = EXC_BAD_ACCESS (code=1, address=0xd1b99620)

There are other similar crashes related to Core3D.

Need an urgent response. Thanks.
Login or Signup to post a comment