Start a new topic

Image wrong rendering

Image wrong rendering


Hi,

can you please send the image to ios-sdk@wikitude.com?

 

Thanks!

Andreas

It  does not contain alpha channel

 

Image: JPMCLogo_thumb.png

  Format: PNG (Portable Network Graphics)

  Class: PseudoClass

  Geometry: 50x50+0+0

  Units: Undefined

  Type: Grayscale

  Endianess: Undefined

  Colorspace: Gray

  Depth: 8-bit

  Channel depth:

    gray: 8-bit


  Properties:

    date:create: 2013-08-08T14:52:21+04:00

    date:modify: 2011-08-17T21:38:37+04:00

    png:IHDR.bit-depth-orig: 8

    png:IHDR.bit_depth: 8

    png:IHDR.color-type-orig: 0

    png:IHDR.color_type: 0 (Grayscale)

    png:IHDR.interlace_method: 0 (Not interlaced)

    png:IHDR.width,height: 50, 50

 


 

Hi,

have you tried different alpha settings? I haven't installed Gimp so I can't give you detailed suggestions what you could try and change. Contains your image an alpha channel?

 

Best regards

Andreas

Thanks Andreas. I opened image with gimp, edited it a little bit and exported. I expect that gimp output is correct. But it is still rendered as on screenshot I attached in my first post. It seems that there's some issues with handling some  kind of correct png images.

Hi,

It seems that the image you try to load is corrupted. Please try another (png, jpg) or export the (png, jpg) again with the correct settings from e.g. photoshop.

 

Best regards

Andreas 

We use the latest 3.0.

We captured ios logs. It contains


 Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGBitmapContextCreate: unsupported parameter combination: 8 integer bits/component; 24 bits/pixel; 3-component color space; kCGImageAlphaNone; 200 bytes/row.

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextSaveGState: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextSetCompositeOperation: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextFillRects: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextRestoreGState: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextSetBlendMode: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextDrawImage: invalid context 0x0

Aug  8 17:59:15 New-Cloud-Pad Empleos PR <Error>: CGContextFlush: invalid context 0x0

 

Can you tell me the SDK version you are using? If you are not using the latest (3.0) can you try upgrading and check again with the new version.

Thanks,
Wolfgang

There's a image that is rendered well in any image viewers. http://s3.amazonaws.com/ja-assets/companylogos/641/JPMCLogo_thumb.png. But it is not rendered properly in AR 

I attached screenshot. Does anyone encounter the same issue?
Login or Signup to post a comment