Start a new topic

Couple of Phonegap questions

Couple of Phonegap questions


I have got the basic sample working fine with Phonegap 2.2.0 on Android (using Eclipse), but I notice the requirements for using the latest Wikitude SDK say use phonegap 2.4.0.

I was just wondering if I am missing out on any functionality by not using Phonegap 2.4.0?


Also, I have modified the basic sample to show a GeoObject landmark (represented by a circle) that is located a few miles away from my current position - I place this object using a GeoLocation with a Long and Lat position of the landmark. This particular GeoLocation/landmark I can on my real horizon, so when i hold the phone up towards it the circle appears where it should (not exact but close enough). When i turn the phone 90 degrees left or right, the circle moves to the side but when i rotate 180 degrees (so the GeoLocation is now behind me) the circle moves back into the middle of the screen, which is incorrect - am I missing something?

My code is:

var myCircle = new AR.Circle(3, {style: {fillColor: '#FFC100'}, opacity : 0.6});

// Long and Lat are declared earlier
var Location1 = new AR.GeoLocation(Long,Lat);

var object1 = new AR.GeoObject(Location1, {drawables: {cam: myCircle}});



Hi Daniel

Please have a look at latest Wikitude PhoneGap Plugin Documentation and find Implementation of Samples on github.

The plugin supports latest PhoneGap only.

Kind regards,
Login or Signup to post a comment