Start a new topic

Script not running after copying the files from WTSampleARBrowser

Script not running after copying the files from WTSampleARBrowser

After including the files in demo to my project. I am unable to get the markers. Now even the status "JSON Objects Loaded".


What could possibly be wrong ?

I've checked the JSON, Locations, javascript to be called.


can you describe your problem in more detail? Which hardware are you using for testing? Where exactly does the error happen?


Kind regards


Hi, Thanks for replying.

Theres no error at all, its just that, I can only see Camera and there are no markers on the screen.

Device Details:

iPhone 4 with iOS 6.1

Have you checked that lat/lon of your POIs are correct and in correct order? You can leave altitude blank for testing purposes. 

Yes, I've checked the locations, anyway they are generated randomly, I've used the code from the Wikitude examples.

I've done a small test, 

hacked throught the architectView to get the webview in it and implemented the webView delegate in my class. 


UIWebView *webview = ;

webview.delegate = self;

In the delegate method I can see the URLRequest is null


- (BOOL)webView:(UIWebView *)webView shouldStartLoadWithRequest:(NSURLRequest *)request navigationType:(UIWebViewNavigationType)navigationType


    return YES;



are you trying to load a local or remote ARchitect World? To me it seems that the if you're using a local resource, the path you pass to the - is simply wrong. Please check your loading path, also check where the main .html file is located in your bundle.


Best regards


I am trying to load the local world. I can see the html file path, even I tried copying the files as folder references, but no luck with it too.


What do you mean my "check loading path ?". .html file is located in Main Bundle.

OKEY solved it.

Never have a space in the App name

If theres a space do encode the path..


You're a life saver!! I would never have thought of that!!


I don't know if this is the best way of going around it but this worked for me :

architectWorldURL = ;
Login or Signup to post a comment