Start a new topic

SDK Model not working

SDK Model not working

Just tested your link.

Problem is with your webserver. As it seems it is not configured to serve .wt3 files. Thus loading the model fails. (unfortunately at a late stage where it is currently not detected. this is something we will need to fix in a future version) 

Thank you for your help thus far.

We have checked it on an iPad (iOS 6) and didn?t have any luck. We were able to create our 2D HTML Drawables, and those displayed without a problem.

The logcat is from the LG Venice, Android 4.0.4. I thought that was the complete logcat, but I ran it again and will attach it to this post.

The other Android was a Motorola Zoom, Android 4.1

Below you will find a link to where the example is being tested:

Click here to go to link.

In the sample folder, there are five other files (not including the HTML file). These are the same files found in the assets folder from the example in the SDK and include: DirectionArrow.png, model.w3t, overlay.png, Wikitude_Logo_SeeMore.png, and I believe that should be everything needed to view the 3D eye example.

Upon loading the web address through the Architect World and viewing the Wikitude_Logo_SeeMore.png, nothing happens. We do see the loading bar, but that?s it. The example was not modified in any way. It was taken exactly from the SDK.

Thank you again.

I cannot find anything unusual in the log. It seems a bit small. Is it the complete log from starting the AR view?

What other Android device did you test it on? Is it working on the iPad?

Did you modify our example in any way? A URL for testing it on our devices internally would be very helpful.



You can find the logcat attached. It's what showed up after I started the example. I'm very new to this, so I can't make much sense out of it, but I hope it helps. I also tried it on a different Android device with no luck either. The logcat below is from the LG Venice. I will be trying it on an iPad this afternoon, but any insight you can provide would be very much appreciated. I'm very impressed with the 2D HTML Drawables and look forward to seeing similiar results with the 3D.

Thank you again.


is there anything showing up in logcat (adb logcat) after you started the example? Have you tried it on a different device?


I have also tried to implement the 3D model example and could not get it to work either. 2D Drawables work great, though. I am viewing it through the ARchitect World in the Wikitude app (downloaded late last week) and have also tried it through the ARchitect Viewer (downloaded today). No luck in either. After the loading bar disappears and I hold over the "eye" image, nothing happens.

I am using an LG Venice, Android 4.0.

Any thoughts?


Below you will find the example code I am working with.

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "">
<meta name="viewport" content="target-densitydpi=device-dpi, width = 540, user-scalable = 0" />
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Simple IR World</title>

<style type="text/css">
  .info {
    color: #9F6000;
    background-color: #FEEFB3;
    margin: -8px 1%;
    padding: 10px;
    font-size: 14pt;
    border-radius: 0 0 10px 10px;
    text-align: center;

<!-- Include the ARchitect library -->
<script src="architect://architect.js"></script>

<script src="../ade.js"></script>


/* Global variables */
var errorOccured = false;

function error() {
  errorOccured = true;
  document.getElementById("messageElement").innerHTML = "Unable to load model or tracker!";

function createTracker(){
  // create the Model
  var model = new AR.Model("model.wt3", {
    scale : {
        x : 0.015,
      y : 0.015,
      z : 0.015
      rotate : {
        tilt : 270
      translate : {
        y : 0.17
      enabled : false
  //the model will appear to roll in from the right side
  //move in from the right
    var moveInAnimation = new AR.PropertyAnimation(model, "translate.x", 2, 0, 2000);
      //simulate rolling
      var rollAnimation = new AR.PropertyAnimation(model, "rotate.roll", 360, 0, 2000);
      //make both animations run at the same time
      model.appearAnimation = new AR.AnimationGroup("parallel", );
  // create tracker
  var trackerDataSetPath = "";
  var logoTracker = new AR.Tracker(trackerDataSetPath, { onLoaded : trackerLoaded, onError: error });

  //start the model animation when the trackable comes into the field of vision
  var trackableOnEnterFieldOfVision = function(){
      model.enabled = true;
  //disable the model when the Trackable is invisible
  var trackableOnExitFieldOfVision = function(){
      model.enabled = false;
  var trackable2DObject = new AR.Trackable2DObject(logoTracker, "Wikitude_Logo_SeeMore", {
      drawables: { cam: },
      onEnterFieldOfVision : trackableOnEnterFieldOfVision,
      onExitFieldOfVision : trackableOnExitFieldOfVision
  var trackable2DObject2 = new AR.Trackable2DObject(logoTracker, "Wikitude_Logo", {
        drawables: { cam: },
        onEnterFieldOfVision : trackableOnEnterFieldOfVision,
        onExitFieldOfVision : trackableOnExitFieldOfVision

function trackerLoaded()
  if (errorOccured) return;

  document.getElementById("messageElement").style.display = "none";



<div class="info" id="messageElement">Loading ...</div>



From a quick look at the code I don't see that anything is wrong wrong with it. Are you using the latest SDK version (2.0) and/or latest Wikitude World Browser app?




I tried to implement the 3D model examples but I could not make it work. Here is the example of my code.


      var path = "";

      var logoTracker = new AR.Tracker(path);

      var pathmodel = "model.wt3";

      var model = new AR.Model(pathmodel);

      var trackable2DObject = new AR.Trackable2DObject(logoTracker, "Wikitude_logo",{ drawables: { cam: model }});
Login or Signup to post a comment