Start a new topic

WTSimpleARBrowser mistakes

WTSimpleARBrowser mistakes

Dear Wikitude,

I just tried your trial for a project we are working on, but i'm not getting anything out of it like promised. When I use the basic code (just exchange my Lati/Longitude, it doesn't do anything.
When I adjust the generatePoi's code so it adds random between -0.0001 & 0.00001, and I set the culling distance to 100K km. Then 1 shows up, but when I look up the location of that GPS coordinate on google maps, first of all, it's the wrong direction, and it should be just a couple meteres away, but the PoI is only like 3x3 mm.
So it's not really doing anything like it's intended to work, also, when i move around, suddenly it bounces through my screen, the same one, and then it's gone.

What goes wrong? I'm not feeling confident for buying the SDK in the current state for the huge project we need it for.


Can you make sure that you not interchanged latitude and longitude?

When using the SimpleARBrowser, normally you only have to replace your latitude/longitude in the file 'WTSecondViewController.h'.

Which device are you using?


Best regards


I changed the latitude and longitude to my current position using ->

It gives me the correct Long/Lat back.
I only changed that, and it did nothing, then I tried editing the rest, and then I could get "something".

I'm currently using an iPhone 5.


have you tried to create your own ARchitect World and load it from a iOS application where you added the WikitudeSDK and load your ARchitectWorld?

Best regards


Yes, when I only change my current position and nothing else, nothing shows. and now I setted the culling distance to 100.000 km. And it shows me only 1.. This doesn't make sense at all.
The demo doesn't use my actual location does it? it uses the location I inserted in the Header file?

I use this ->


#define YOUR_CURRENT_LATITUDE 51.220919



Which makes sense, since my adress should be there.

I found the solution, the problem was iOS itself, I had restriction on for making changes to location services for when my phone is stolen. That disabled all the functionality. I got it working now.




I'm facing the same issue. I haven't created my own world. I'm just using the one given by the app, but it is not showing any point. I have checked all what was said in the previous messages as well.


Do you have location restrictions on?

No. I have made it work adding this. ;

Should it work as well without this?


This basically tells the architect view to render all POI's within 100 km radius.
So if you're poi's are within that, they will show up, otherwise not ^_-

I made this change because, if I understood well, per default it is 50km, and I wasn't seing any of the 50 points created by default. I checked some of them, and they were inside the 50 km radius.

Can you think in any reason why this is happening?

Yes, it looks like it is not updating the location of the mobile... 

Please check following things:

The following defines are set to your current location:







use a service like to verify the location.


Add following code to the archtiect world to see what location is reported by iOS


AR.context.onLocationChanged = function(latitude, longitude, altitude, accuracy){

alert('lat: ' + latitude + ' lon: ' + longitude + ' alt: ' + altitude);



This will output an alert each time the location changes and will let you know the exact location used. Compare that to the location you defined.


Keep in mind:

- this is only a sample, the defines are only used to create 50 points around that location

- in a real application all POI locations should come from real world location


Let me know if you have further questions


I have realised that it only doesn't work with iOS 5. It works with iOS 6. Is that how it should be?



Login or Signup to post a comment