Start a new topic

Vuforia QCAR SDK (2.0.30) Problems with latest Wikitude SDK (1.2)

Vuforia QCAR SDK (2.0.30) Problems with latest Wikitude SDK (1.2)


Yeah, sorry for that!
It was my fault, i indeed did not correctly include the Vuforia SDK.

The instructions are not totally clear regarding all the single steps one has to do to make it work though too..
(It ain't exactly newbie friendly, so to say... ;-)=)

I got it working now after consulting the Vuforia developer guide.
(I hadn't added a classpath variable pointing to the installed SDK files / folder, and i also had forgotten to tick the SDK .jar file in the java build path "Order and Export" settings)

Hi Christian,

thanks for your message. The latest Vuforia SDK and the latest Wikitude SDK do work together, so there shouldn't be any compatibility issue here. The SDK package comes with a detailled instruction how to include the Vuforia SDK in your project - probably the SDK was not included correctly?

Nevertheless, our Android team will look into the issue and check if they can reproduce this behavior on the device you've mentioned. They will get back to you as soon as possible.

Best regards,

Martin

Hi there,

i am trying to get your "SimpleIRExample" project running on my HTC One S device (Android 4.1.1).

It does compile without problems, but immediately crashes on startup every time.

I am using your latest ARchitect SDK (1.2) and the current (latest?) Vuforia SDK (QCAR 2.0.30)

Btw., the links to the Vuforia SDK, that you are posting here on this site are not available anymore!

I had to google QCAR / Vuforia to find the current SDK downloads.

Is it possible, that the latest versions of the SDKs don't work together anymore?

The problems seems to be, that the QCAR Library and it's static functions never get instantiated, or ain't available on the device, and so a call to the static init() method immediately crashes the application.

Any hints are welcome, thank you!
Login or Signup to post a comment