Start a new topic

Android ArchitectView crash with a lot of objects added

Android ArchitectView crash with a lot of objects added

Hello gentlemen,

First of all thank you for such a great tool as Wikitude SDK.

We've recently started using the 1.1 version for our Android app and came upon an issue where the application crashes if we add a lot of objects to the AR view (part of stack trace that is suspected to cause the trouble is attached). By "a lot" I mean about 70 markers consisting of image and label each. The issue is reproduced on a variety of devices (milestone, nexus, etc.) on different OS (2.2, 4.0, etc.).

Have you heard of something similar from the other users? Is there a known limit of the objects that can be added?

Thanks in advance for your answers

Hi, this looks like a bug on our side, but we will need a bit more time to verify and fix. In the meantime any additional information will help us.


Is it consitently reproducesable?
When does it happen? (startup, creation of pois, pausing/resuming the activity, shutdown, ...)
Are there devices on which it work?
Which nexus device are you using (one, s, galaxy)?



Hi Wolfgang,

Thanks for the fast reply.

I can reproduce this issue in 100% on Milestone with Froyo. It looks like the older devices are affected more than the new ones however which is probably not surprising if this problem is connected to memory.

The scenario is as follows - activity starts, we initialize the AR view on all steps and load the html. Then we start throwing in the data, the new objects start to appear in the view but after some amount of them shown everything freezes and the activity bails out with no message. If the amount of data is less (say 20-30 POIs instead of 60-70 which cause trouble) - it works fine.

I'll get back with the details about other devices we have tested with.

Thanks for the additional info. Milestone is already a pretty old device thus I would be interested in the results on newer devices, if available.

This crash is currently reproduced on 2 devices only - Milestone and GT-19000 (which doesn't have a compass anyway, it's funny though how it got through the isDeviceSupported() check).

Nexus phones don't have this problem (we've got another crash there which we'll post in a separate thread).

Do you suggest we blacklist the Milestone? It still works fine with 20-30 POIs loaded. So I guess we can live with it if that's the problem with old devices only. Can you name others which might have the same issue?

I won't blacklist the Milestone. We do support it with our Wiktiude World Browser that is built using the same SDK. However if until we have a fix for the problem, I would limit the number of POIs on this device.

Furthermore I'm curios what version you have of the Galaxy S. Our Galaxy S devices do have a compass and the Galaxy S spec also lists a compass.

It seems that Galaxy S that was used for testing might have the custom modified firmware that is causing the problems, never mind it.

We will go with limited POIs for Milestone for now. Please update us if this issue is resolved. 
Login or Signup to post a comment