Start a new topic

Unable to run with xcode 4.5

Unable to run with xcode 4.5


I just installed the new version of xcode 4.5  and it seems it can no longer run the simpleIRexample as I encounter error warning below.

ld: file is universal (2 slices) but does not contain a(n) armv7s slice: //libQCAR.a for architecture armv7s

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Please advice on what to do. Thank you.


in order to build your App with Xcode 4.5, you need to remove the armv7s architecture from your valid architectures in your project settings. 

To do that, open your projects build settings and edit the valid architectured accordingly (double click and remove armv7s from the menu). 



Best regards



I'm having the same issue with the IRAndGeoBrowser sample project. I've removed armv7 from Valid Architectures from both the Project settings and Target settings but now I get:


Check dependencies

No architectures to compile for (ARCHS=armv7 armv7s, VALID_ARCHS=).


Can someone please help me with this?


This may be a silly question but did you download the QCAR SDK from Qualcomm and put it into the proper folders within the example?


You need to have at least armv7 as valid architecture. You just need to remove armv7s.

Best regards


Indeed, the QCAR SDK wasn't copied into the proper folders.

Worth mentioning that the QCAR SDK is now called Vuforia and you can download it from here:

Thanks guys!
Login or Signup to post a comment