Start a new topic

SDK Bug?

SDK Bug?


I used "wikitude SDK 1.1.2" develop a app five months ago.
But now it can't run on my HTC Desire.
What's wrong is it?

other question.
I used the "WikitudeSDK_1_0_5" android sample.
But it get some error.
This is the message on eclipse:
The library 'wikitudesdk.jar' contains native libraries that will not run on the device.
The following libraries were found:
- libs/armeabi/

Please help me.
Thank you very much. ^^"

First of all thank you for your interest in our SDK.

The problem you are facing should be addressed in the Documentation of the SDK:

Attention for Eclipse Users:

In some Versions of the Android Eclipse plugin the inclusion of the Library may result in a compile time error like this:

In that case please go to the Eclipse preferences menu and uncheck the following options under Android ? Build: ?Force error when external jars contain native libraries?.

IMPORTANT: Due to a bug in the Android Eclipse plugin (r16) it might be necessary to uncheck the option ?Automatically refresh Resources and Assets folder on build? instead.

The mentioned bug was fixed in the current release (r19) of the Eclipse plugin.

Hope this helps

Hi. I'm experiencing the same issue. 

After I uncheck the 'force error...' option, I get the following errors:


Installation failed due to invalid APK file!

Please check logcat output for more details.

Launch canceled!


I also tried unchecking the second option you mentioned (tried with only the second one and both unchecked).


Logcat doesn't throw any errors, but there's a warning. It says it's unable to read AndroidManifest.xml, which is, of course, present.


I have only followed the instructions from the github repo and haven't done anything else (the app was running before I installed wikitude).


Can you please help me ?

Hi there!

Seems as if you have an Android / Eclipse problem.
In most cases pressing "Project" - "Clean..." in the menu-bar solves the issue.
Please have a look at the SDK Documentation for Android and ensure you have very latest Android Plugin installed.

Hope that help,


I'm having the same error:

Installation failed due to invalid APK file!

Please check logcat output for more details.

Launch canceled!


As you can see, I'm trying to run the provided examples on the SDK. I haven't touched anything, just open the proyect and Run As Android Application. Of course I have all the latest versions of ADT (Rev 21.1) and Android SDK Platfrom Tools (Rev16). A "clean" to the project has been also performed.

Would you please advice on the way forward?


Hi there!

I also have this issue every once in a while. It is an Eclipse set-up problem.
In case you're sure you did everything properly try deleting the bin-folder and clean your project, that helped in one of my cases.

Kind regards,
Login or Signup to post a comment